
Mac OS 8: Internet Explorer Read Me

TOPIC 

This article is the Internet Explorer Read Me file that comes with Mac OS 8.0. 

DISCUSSION 

Microsoft Internet Explorer 3.01 for Macintosh
Thank you for choosing Microsoft Internet Explorer for Macintosh. Although
Internet Explorer 3.01 has
dozens of new features, by the time you read this, there may already be a new
version of Internet
Explorer, so please check out http://www.microsoft.com/ie/mac periodically for
updates. 

Microsoft Internet Explorer is a World Wide Web (WWW) browser for the Macintosh.
The WWW is the
fastest growing component of the Internet today. In order to use a WWW browser,
you will need a
modem or network access, access to the Internet, and software that enables your
computer to
communicate with the Internet. 

Microsoft Internet Mail and News, our small and fast e-mail client, and
Microsoft Personal Web
Server, which turns any Mac into a Web serving solution are not included in this
installer. You can
visit http://www.microsoft.com/ie/mac to download these products. 

Registering Internet Explorer
We've made it even easier for you to register Internet Explorer 3.01. The first
time you open Internet
Explorer, you will automatically visit our online registration site at
http://www.microsoft.com/ie/ie_reg.htm. Remember that this only occurs the first
time you open
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Internet Explorer after installation. The next time you open Internet Explorer,
you will visit your default
home page. For more information, see the License Agreement. 

Requirements 

System Requirements

       Macintosh with 68030 or higher processor 
       System 7.1 and higher
       8 MB of RAM 
       7 MB of hard disk space when Internet Explorer is installed. 

Access to the Internet
You must have access to the Internet through an Internet Service Provider or the
network to which
your computer is connected. 

Internet software

       Open Transport 1.0.8 or greater (Extension) or Mac TCP
       If you are a dial-up user, Config PPP or similar PPP connection software
(Control Panel) with
       PPP (Extension) 

New Features
Version 3.01 of Internet Explorer represents a surprisingly large number of new
features, so be sure
to take a look at the following: 

JavaScript
JavaScript is the easiest and fastest way for Web authors to add interactivity
to a Web site. Unlike
Java, which is based on separate software components, JavaScript is a scripting
language whose
programs are embedded right in the HTML. You can use the Preferences dialog box
to turn scripting
on and off. 

Choose your Java virtual machine
Settings in the Preferences dialog box give you greater control over the use of
Java:

       You can choose which Java virtual machine you would like to use:
Microsoft VM or Microsoft
       JIT. If Apple MRJ is already installed on your machine, you can choose
it. 
       You can specify whether a warning should be displayed if there are errors
in the Java applet
       or whether the browser should save the output text from the Java applet.

Downloading files
The Download File command in the File menu lets you download files from the



Internet while you
continue to browse other Web pages. Once you have typed the URL of the file you
want to download,
the Download Manager will open and give you information on the status, size, and
download time of
the file. The Download Manager is also available from the File menu and it keeps
a history of the
files you have downloaded. You can double-click the downloaded item in the
Download Manager for
more information. 

Internet Explorer now supports folder downloads from FTP and Gopher sites. Drag
and drop the
folder to the Finder to download the contents of the folder. You can also press
and hold down the
mouse button over an item on the Web page, and then choose Download Link to Disk
from the
context menu. 

Enhanced download options include automatically decoding BinHex and MacBinary
files while the
file is being downloaded. 

Manage site passwords and user names
The Site Passwords page in the Preferences dialog box maintains a list of the
user names and
passwords you have used to access a site. Now, you can change access information
without going
to the site. 

Receive updates to your favorite pages
When you mark favorite pages as subscribed pages, Internet Explorer will monitor
those sites and
notify you, when and if a subscribed page changes. To select how often you want
Internet Explorer to
look for changes, and how you want to be notified of changes, choose
Subscription Options from the
Favorites menu. 

Note: This is a subset of the Subscription functionality that will be included
in the Internet Explorer
4.0 platform preview. 

Improved favorites
You can sort favorite items, rename the path, and resize the columns in the
favorites list. In addition,
you can turn a subscription to a favorite page on and off by clicking in the
Subscriptions column (the
left most column in the Favorites window). To change subscription information
for a particular item,
double-click the subscriptions icon located beside the favorite item. 

Manage cookies



A cookie is a small piece of information that a Web site downloads on your hard
disk for future
reference. For example, a cookie might be used to store a customized view of a
Web site or ensure
that you never see the same advertisement twice. Settings in the Internet
Explorer Preferences
dialog box let you control the download of cookies. For example, you can choose
to always accept
cookies or you can choose to always display an alert when a Web site wants to
download cookies. 

Autosearch
Internet Explorer has made searching the Internet even easier with the
Autosearch feature. Simply
type go or ? and the topic you'd like to search for in the Address Bar, and
Yahoo! (www.yahoo.com)
will search its databases for matching topics and display them for you. For
example, type ? cooking
to find all references to cooking in the Yahoo! database. 

Fetch bookmarks
Do you have Fetch bookmarks? Now, you can import them into Internet Explorer.
Drag and drop your
Fetch bookmarks into the Favorites window of Internet Explorer. 

Type ahead in the Address bar
Type an address into the Address bar and Internet Explorer can attempt to
complete the address
using the contents of your favorites and history lists. First, Internet Explorer
will review the names
and addresses in your favorites list, and then, if it doesn't find a match, it
will review the names and
addresses in your history list. For example, if you recently visited the
Microsoft site at
http://www.microsoft.com, you might need to type only the letters Mic or
http://www.mic before
Internet Explorer displays the complete address for you. 

You can turn off this option by choosing Preferences from the Edit menu,
clicking the Browser
Display under Web Browser, and then clearing the Auto-Complete Addresses check
box. 

Refreshing a Web page from the context menu
You can reload a Web page quickly by using the Refresh command from the context
menu. This
feature is especially useful when you want to refresh the contents of a file
contained in a frame.
Simplyclick inside the frame, hold down the mouse button, and choose Refresh
from the context
menu. 

Preferences and Internet Config



Internet Explorer is now more closely integrated with Internet Config and works
with the preferences
file for Internet Config directly. You no longer have to select whether or not
you want to use Internet
Config. Any settings you change in the Internet Explorer Preferences dialog box
automatically go to
the Internet Config Preferences file. If you currently use the Internet Config
application, you can
continue to do so and the changes you make will automatically appear in Internet
Explorer. 

More preferences are now available from the Preferences dialog box to better
customize your
browsing experience. You can control animated GIFs, file downloads, Java VMs,
proxies and other
features. 

ActiveX update
We now have a new version of the ActiveX SDK that supports ActiveX scripting.
For more information
on this feature, please go to the ActiveX SDK site at
http://www.microsoft.com/intdev/sdk/mac. 

Known Issues 

Installing from the CD
Internet Explorer Installer requires that the startup disk of your computer is a
hard disk. You will get
an error during installation if your startup disk is a CD ROM drive. If this
occurs, restart your
computer and then run the Internet Explorer installer. 

Java
You may not be able to view large Java applets on 8 MB machines when there is
not enough system
memory free. This occurs because the Java virtual machine is loaded and unloaded
dynamically in
the system memory. Memory is used only when you view pages with Java
applications. 

A 68K JIT is not available at this time. If you are a 68K user make sure that
you choose the MSIE/MW
VM or the Apple VM (if installed). Please visit http://www.microsoft.com/ie/mac
for updates. 

ActiveX
Microsoft Internet Explorer 3.01 for Macintosh has native ActiveX support, and
does not require the
use of a plug-in. The Microsoft ActiveX Plug-in included with this installer is
for use with older
versions of Internet Explorer or other browsers that use plug-ins and do not
have native support for
ActiveX. 



Some Web pages may have ActiveX controls that do not support Mac OS. If this
happens and you
are unable to view the page, you can turn off viewing of ActiveX content. To do
so, choose
Preferences from the Edit menu, click Web Content under Web Browser, and then
clear the Enable
ActiveX check box. 

Note: Please be aware that in this release, Internet Explorer cannot verify the
integrity of ActiveX
controls. Download and use ActiveX controls from trusted servers only. 

Protocol helpers
You can use the Preferences dialog box to assign protocol helpers. When you do
so, please note
that the Use Current Application If Possible check box is turned on by default
so that if Internet
Explorer can handle the protocol, it will be used instead of the assigned
helper. For example, if you
have assigned Fetch as your current FTP (File Transfer Protocol) helper and have
not cleared the
Use Current Application If Possible check box, when you click an FTP link in
Internet Explorer,
Internet Explorer will be used to download the file, not Fetch. 

If you do not want Internet Explorer to handle a protocol, be sure to clear the
Use Current Application
If Possible check box. 

Real Player 4.0b1
The current beta version of the Real Player 4.0b1 installer may corrupt the
Internet Preferences file,
in which Internet Explorer stores its preferences. If this occurs, delete the
Internet Preferences file
(located in your Preferences folder inside your System folder). The next time
you open Internet
Explorer, a new Internet Preferences file will be created. 

QuickTime and PowerPlug
If you have QuickTime installed, Internet Explorer requires that the QuickTime
PowerPlug be
installed in the Extensions folder in your System folder. QuickTime extensions
are available for
download from http://quicktime.apple.com. 

QuickTime and QuickDraw 3D
If you use the Extensions Manager to disable QuickTime and QuickDraw 3D, you
need to remove the
appropriate QuickTime and QuickDraw 3D libraries. 

VRML
If you are using Internet Explorer to view VRML pages, you must have QuickDraw



3D version 1.5 or
later installed. QuickDraw 3D is available for download from
http://quickdraw3d.apple.com/. 

Internet Config File Mappings table
Internet Explorer maintains an internal list of viewers that tells it how to
handle different types of
documents. In this release, this list is exported and merged with the Internet
Config File Mappings
table. As a result, please consider the following:

       Internet Explorer's list of viewers is indexed by the MIME types
(Multimedia Internet Mail
       Extensions) of incoming documents. Since Internet Explorer cannot use a
viewer without a
       MIME type, it will ignore them, but not delete or alter file mappings in
Internet Config that do
       not contain a MIME type.
       Internet Explorer maintains only one table entry per MIME type. If you
have multiple file
       mappings in Internet Config with the same MIME type, Internet Explorer
will use only the last
       setting in the table.
       Internet Explorer adds a small amount of information to each file mapping
in Internet Config
       to store its How to Handle setting. When you choose Use Explorer as a
Viewer, Internet
       Explorer always attempts to handle the document type, regardless of the
settings in Internet
       Config. Most file formats use the viewer specified in Internet Config,
however, certain file
       formats like GIF and JPEG are handled by Internet Explorer regardless of
your Internet Config
       setting.

Using Help
Internet Explorer Help is available from the Help (?) menu and will give you the
information you need
to use the powerful features of Internet Explorer. 

1. Click a topic area on the left to see a list of related procedures. To open
the procedures in a
separate window, press and hold on the topic area link and then choose Open Link
from the context
sensitive menu. 

2. Click Index to see the Index. Use the Index just as you would an index in a
book. 

3. Click Tips & Tricks for information about a particular menu item and its
keyboard shortcut. 

4. Internet Explorer Help is best viewed in Internet Explorer. 



5. Click the Internet Explorer logo at the bottom of the topics list to visit
the Internet Products home
page at www.microsoft.com/ie/mac. 

6. For best viewing, choose Preferences from the Edit menu, click the Web
Content tab, and make
sure Allow Page To Specify Colors is selected. 

7. To print, click in the frame that contains the information you want, and then
choose Print from the
File menu. 

Reporting problems and making suggestions
Send mail to giraffe@microsoft.com with your suggestions. Include: 

       System configuration information (on the Apple menu, choose About
Internet Explorer, and
       then click Support). 
       Version of operating system 
       Type of Macintosh 
       Type of connection to the Internet 
       Steps that lead to the problem. For example: 

1. Start Microsoft Internet Explorer. 

2. From the File menu, choose Open. 

3. Click the Cancel button. 

4. Result: Nothing happens. 

Any other information that will help us reproduce the bug successfully. 

Although you will not receive a response via e-mail, all your messages will be
read and evaluated by
the engineering team. We appreciate your feedback. 

Technical support
Microsoft offers 90 days of product support at (206) 635-7123 in the U.S. and
(905) 568-4494 in
Canada. This support is free of charge, except for the cost of the telephone
call. 

Visit the Internet Explorer for Macintosh home page
Learn more about the many features and updates of Internet Explorer by visiting
our home page at
http://www.microsoft.com/ie/mac. 

Join the Internet Explorer for Macintosh newsgroup
Interact with other users of Internet Explorer for Macintosh by joining
microsoft.public.inetexplorer.mac. For more information, please visit the



Technical Support
Newsgroup page at http://www.microsoft.com/support/news/. 

Redistribute Microsoft Internet Explorer--royalty free!
With the Internet Explorer Administration Kit 3.0 for the Macintosh, users can
deploy Internet Explorer
across an organization, or distribute it with their applications. You do not
have to pay royalties when
redistributing Internet Explorer, just a small fee for shipping and handling of
the CD. To receive the
Internet Explorer Administration Kit, check out
http://www.microsoft.com/ie/ieak. 

Java Virtual Machine components for Internet Explorer 3.01
Microsoft Internet Explorer 3.01 Java support is based on the JManager interface
as defined by
Apple Computer, Inc. Internet Explorer has an open architecture that supports
multiple Java Virtual
Machines such as the Apple Java Virtual Machine, MSIE/MW VM, and MSIE/MW PPC_JIT
VM. 

To enable Java in Internet Explorer: 

1. Choose Preferences from the Edit menu. 

2. Click Java under Web Browser, and make sure the Enable Java check box is
selected. 

3. To change your VM, choose it from the Java Virtual Machine menu. 

Java VM pop-up menu will be grayed out, if a Java VM is not installed on your
machine. To install
Java VM see the instructions in The Apple VM below. 

The Apple VM
Internet Explorer uses the Apple Java Virtual Machine that comes with your
system software. If not
installed please install it from the Mac OS System Software CD or download and
install it from
http://applejava.apple.com/. 

The Microsoft Java VM 
The Microsoft Java VM was jointly developed by Microsoft and Metrowerks and is
available in two
flavors: MSIE/MW VM and MSIE/MW PPC_JIT VM. You may use either the MSIE/MW VM or
MSIE/MW
PPC_JIT VM with Internet Explorer, but one may be better suited to your needs. 

The Microsoft Java VM in not included in this version of the Internet Explorer
Installer. The MSIE/MW
VM can be downloaded from http://www.microsoft.com/ie/download. Follow the
instructions to
install, and change Internet Explorer Preferences as noted above to choose from



the different Java
Virtual Machines. 

The MSIE/MW VM is installed with Internet Explorer requires less memory and lets
you debug Java
applets. The MSIE/MW PPC_JIT VM includes technology known as a Just In Time
(JIT) compiler. The
JIT takes standard Java byte codes and compiles them into native PowerPC
instructions. For
computational applets, you will see a dramatic increase in speed. Graphics
speed, however, will
remain largely unaffected. The JIT VM does not support debugging and it requires
more RAM
because PowerPC code is larger than Java byte-code. 

Note: A 68K JIT is not available at this time. If you are a 68K user make sure
that you choose the
MSIE/MW VM or the Apple VM (if installed). 

____________________ 

QuickTime, QuickTime VR, and the QuickTime logo are all trademarks of Apple
Computer Inc.
Macintosh is a registered trademark of Apple Computer. 

Java is a registered trademark of Sun Microsystems, Inc. 
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